Enforced Google Safe Search Stopped Working

Issue:

Our enforced google safe search via split DNS stopped working recently.  Students were getting a 404 error when trying to reach google to search.

 

Solution:

The dname (domain alias) record on our DNS server stopped working because of a windows update.

Uninstall one update below reboot the server and see if the problem resolves, repeat until the problem stops occurring.  I uninstalled the first update in the list and that fixed the problem for me.

  • KB3179574
  • KB3185259
  • KB3185331
  • KB3133954
  • KB3161591
  • KB3185279
  • KB3192404

 

How to get a list of all Windows Server Updates in a searchable text file:

wmic qfe list brief /format:texttablewsys > "c:\temp\hotfix.txt"

 

Alternate Solution:

If uninstalling these updates does not work then in DNS add “A” record with blank “Host” to point to the static ip address when you ping “forcesafesearch.google.com” to each of the split DNS domains you setup.

 

Resources:

How to Setup Restricted Google Safe Search: https://support.opendns.com/hc/en-us/articles/227986807-How-to-Enforcing-Google-SafeSearch-YouTube-and-Bing

https://serverfault.com/questions/810529/server-2012-dns-server-not-resolving-all-forward-lookup-zones

https://social.technet.microsoft.com/Forums/en-US/c1190de4-e735-4828-928f-842b31d2c30b/dns-dname-issue?forum=winserveripamdhcpdns

https://productforums.google.com/forum/#!topic/websearch/F_IOOSWaswI

 

Leave a Reply

%d bloggers like this: